<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED FIXED - Expose a WKWebView API for allowing programmatic focus to trigger node assistance"
   href="https://bugs.webkit.org/show_bug.cgi?id=149567#c7">Comment # 7</a>
              on <a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED FIXED - Expose a WKWebView API for allowing programmatic focus to trigger node assistance"
   href="https://bugs.webkit.org/show_bug.cgi?id=149567">bug 149567</a>
              from <span class="vcard"><a class="email" href="mailto:wenson_hsieh&#64;apple.com" title="Wenson Hsieh &lt;wenson_hsieh&#64;apple.com&gt;"> <span class="fn">Wenson Hsieh</span></a>
</span></b>
        <pre>Comment on <span class=""><a href="attachment.cgi?id=261960&amp;action=diff" name="attach_261960" title="Patch">attachment 261960</a> <a href="attachment.cgi?id=261960&amp;action=edit" title="Patch">[details]</a></span>
Patch

View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=261960&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=261960&amp;action=review</a>

<span class="quote">&gt;&gt; Source/WebKit2/UIProcess/API/Cocoa/WKWebView.h:248
&gt;&gt; +&#64;property (nonatomic) BOOL canAssistOnProgrammaticFocus;
&gt; 
&gt; This API declaration is missing availability information.
&gt; 
&gt; It’s surprising that this API uses the term “assist”. Is this something that’s used anywhere else in WebKit or UIKit API?
&gt; 
&gt; Have you considered other ways to expose this ability to clients? For example, calling the delegate when an element is focused and asking it to make a decision seems like it would afford more flexibility.</span >

Just to make sure -- would I add availability information via something like WK_AVAILABLE(10_12, 10_0)?

Good point, it looks like assistance is not really mentioned in the WebKit API and in UIKit it refers to accessibility-related things rather than bringing up the keyboard. Maybe I could rephrase it to be something like &quot;A Boolean value indicating whether programmatic focus on an element is allowed to display the keyboard.&quot; Also, now that I'm aware keyboardDisplayRequiresUserAction exists for UIWebView, I think we should rename this flag to keyboardDisplayRequiresUserAction for better consistency.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>