[Webkit-unassigned] [Bug 148882] Implement all the arithmetic and logical instructions in WebAssembly

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 8 10:42:52 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=148882

--- Comment #4 from Sukolsak Sakshuwong <sukolsak at gmail.com> ---
(In reply to comment #3)
> Comment on attachment 260730 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=260730&action=review
> 
> r=me
> 
> > Source/JavaScriptCore/tests/stress/wasm-arithmetic.js:45
> > +        return (6 * 7) | 0;
> 
> What's stopping the WASM compiler from just constant folding this operation
> and just returning a constant (thereby defeating this test)?  Why not pass
> the values into the test functions as arguments?  Unless there's a reason to
> not do so, please pass the args in to the test instead.  I'm fine with doing
> a follow up patch to update all the tests to do this.

pack-asmjs does not do constant folding. (I don't think they will ever do it. Optimization of asm.js should be done by Emscripten's.) But I will do it to be future-proof. It should also make the code easier to read.

> > Source/JavaScriptCore/tests/stress/wasm-arithmetic.js:192
> > +shouldBe(module.multiplyOverflow(), -2147483648);
> 
> What does it mean to multiplyOverflow?  Does WASM require that we overflow
> silently?

multiplyOverflow = the result from multiplication is larger than INT32_MAX. The WASM spec says "Sign-agnostic operations silently wrap overflowing results into the result type." It also says that multiplication on 32-bit integers is a sign-agnostic operation. <https://github.com/WebAssembly/design/blob/master/AstSemantics.md>

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150908/41eb7d77/attachment.html>


More information about the webkit-unassigned mailing list