[Webkit-unassigned] [Bug 148967] AX: ARIA 1.1 implement aria-colcount, aria-colindex, aria-colspan, aria-rowcount, aria-rowindex and aria-rowspan

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 9 14:12:03 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=148967

--- Comment #4 from chris fleizach <cfleizach at apple.com> ---
Comment on attachment 262789
  --> https://bugs.webkit.org/attachment.cgi?id=262789
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=262789&action=review

whats the plan for exposing this on iOS?

> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:96
> +    unsigned rowSpan = ariaRowSpan();

how do we distinguish 0 from no value?

> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:101
> +        rowSpan = 1;

can you put this blob into a separate method

> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:145
> +}

i know that column/rowIndex are used by VO to get data out of the table sometimes. will this mess things up?

> Source/WebCore/accessibility/AccessibilityTable.cpp:695
> +    int rowCountInt = rowCountValue.toInt();

if there's no aria_rowCount set, won't toInt() == 0? which seems like the wrong default value right

> Source/WebCore/accessibility/AccessibilityTableRow.cpp:152
> +    for (unsigned i = 0; i < rowChildren.size(); i++) {

are we able to use the better iterators for accessibility children

for (const auto& cell in rowChildren)

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151009/28114085/attachment.html>


More information about the webkit-unassigned mailing list