[Webkit-unassigned] [Bug 149338] [ES6] "super" and "this" should be lexically bound inside an arrow function and should live in a JSLexicalEnvironment
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sat Nov 14 14:22:42 PST 2015
https://bugs.webkit.org/show_bug.cgi?id=149338
--- Comment #105 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 265543
--> https://bugs.webkit.org/attachment.cgi?id=265543
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=265543&action=review
> Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:846
> + auto protoObject = environment.add(propertyNames().derivedConstructorPrivateName);
Nit: I would call this variable a different name after your renaming.
> Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:3857
> + if (m_resolvedArrowFunctionScopeContextRegister == nullptr)
Style: I think it's official WebKit style to check "!m_resolved..." Instead of "m_resolved... == nullptr"
> Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:3863
> +void BytecodeGenerator::emitGetThisFromArrowFunctionLexicalEnvironment()
Style: I would call this "emitLoad..." Instead of "emitGet..."
And the same below
> Source/JavaScriptCore/runtime/Executable.cpp:137
> + , m_features((isInStrictContext ? StrictModeFeature : 0) | (isInArrowFunctionContext ? ArrowFunctionContextFeature : 0))
This seems awkward, actually. I'm not sure why we just have
the features mean one thing here. I think it's probably better just
to have a separate property like you had before.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151114/6bb27445/attachment.html>
More information about the webkit-unassigned
mailing list