<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [ES6] &quot;super&quot; and &quot;this&quot; should be lexically bound inside an arrow function and should live in a JSLexicalEnvironment"
   href="https://bugs.webkit.org/show_bug.cgi?id=149338#c105">Comment # 105</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [ES6] &quot;super&quot; and &quot;this&quot; should be lexically bound inside an arrow function and should live in a JSLexicalEnvironment"
   href="https://bugs.webkit.org/show_bug.cgi?id=149338">bug 149338</a>
              from <span class="vcard"><a class="email" href="mailto:sbarati&#64;apple.com" title="Saam Barati &lt;sbarati&#64;apple.com&gt;"> <span class="fn">Saam Barati</span></a>
</span></b>
        <pre>Comment on <span class=""><a href="attachment.cgi?id=265543&amp;action=diff" name="attach_265543" title="Patch">attachment 265543</a> <a href="attachment.cgi?id=265543&amp;action=edit" title="Patch">[details]</a></span>
Patch

View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=265543&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=265543&amp;action=review</a>

<span class="quote">&gt; Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:846
&gt; +        auto protoObject = environment.add(propertyNames().derivedConstructorPrivateName);</span >

Nit: I would call this variable a different name after your renaming.

<span class="quote">&gt; Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:3857
&gt; +    if (m_resolvedArrowFunctionScopeContextRegister == nullptr)</span >

Style: I think it's official WebKit style to check &quot;!m_resolved...&quot; Instead of &quot;m_resolved... == nullptr&quot;

<span class="quote">&gt; Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:3863
&gt; +void BytecodeGenerator::emitGetThisFromArrowFunctionLexicalEnvironment()</span >

Style: I would call this &quot;emitLoad...&quot; Instead of &quot;emitGet...&quot;
And the same below

<span class="quote">&gt; Source/JavaScriptCore/runtime/Executable.cpp:137
&gt; +    , m_features((isInStrictContext ? StrictModeFeature : 0) | (isInArrowFunctionContext ? ArrowFunctionContextFeature : 0))</span >

This seems awkward, actually. I'm not sure why we just have
the features mean one thing here. I think it's probably better just
to have a separate property like you had before.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>