[Webkit-unassigned] [Bug 145285] previousRootInlineBoxCandidatePosition & nextRootInlineBoxCandidatePosition FIXME to remove duplicate code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 26 11:42:58 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=145285

Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #253551|review?                     |review-
              Flags|                            |

--- Comment #9 from Darin Adler <darin at apple.com> ---
Comment on attachment 253551
  --> https://bugs.webkit.org/attachment.cgi?id=253551
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=253551&action=review

Does seem like an improvement. But we should do a little more to make this even better.

> Source/WebCore/editing/VisibleUnits.cpp:78
> +};

Extraneous semicolon here. This should be an enum class, not a namespaced non-class enum.

> Source/WebCore/editing/VisibleUnits.cpp:83
> +    Node* leaf = direction == BoxCandidatePosition::Next ? nextLeafWithSameEditability(node, editableType) : previousLeafWithSameEditability(node, editableType);

I think this would read better with a helper function to avoid the ? : every time.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150526/cc02f01a/attachment.html>


More information about the webkit-unassigned mailing list