[Webkit-unassigned] [Bug 145065] Prefix force on MouseEvent and add constants for click and force click values

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 15 12:06:13 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=145065

--- Comment #4 from Tim Horton <thorton at apple.com> ---
(In reply to comment #3)
> Comment on attachment 253211 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=253211&action=review
> 
> > Source/WebCore/dom/MouseEvent.h:95
> >      double force() const { return m_force; }
> > +    double webkitForce() const { return m_force; }
> 
> Isn't there a way in the IDL to have an alias like this without having to
> have the function twice?

Yes! I think you want something like this:

[Conditional=MOUSE_FORCE_EVENTS, ImplementedAs=force] readonly attribute double webkitForce;

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150515/3e68881a/attachment.html>


More information about the webkit-unassigned mailing list