[Webkit-unassigned] [Bug 144762] Fix internal build configuration issues

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 8 09:27:47 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=144762

David Kilzer (:ddkilzer) <ddkilzer at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #252655|review?, commit-queue?      |review-, commit-queue-
              Flags|                            |

--- Comment #7 from David Kilzer (:ddkilzer) <ddkilzer at webkit.org> ---
Comment on attachment 252655
  --> https://bugs.webkit.org/attachment.cgi?id=252655
More bug fixes (thanks Joe!)

View in context: https://bugs.webkit.org/attachment.cgi?id=252655&action=review

Please make corrections above and post a new patch.

> Tools/DumpRenderTree/mac/Configurations/Base.xcconfig:30
> +HEADER_SEARCH_PATHS = $(BUILT_PRODUCTS_DIR)/usr/local/include $(BUILT_PRODUCTS_DIR)/WebCoreTestSupport ForwardingHeaders $(MAYBE_HEADER_SEARCH_PATHS) $(SRCROOT)/../../Source/JavaScriptCore/icu;
> +MAYBE_HEADER_SEARCH_PATHS[sdk=iphone*] = $(SDKROOT)/usr/local/include $(SDKROOT)/usr/local/include/WebCoreTestSupport $(SRCROOT)/../../Source/WebKit2/Platform/spi/ios;

Please rename MAYBE_HEADER_SEARCH_PATHS to PLATFORM_HEADER_SEARCH_PATHS.  I think "PLATFORM" is more descriptive than "MAYBE" here.

> Tools/DumpRenderTree/mac/Configurations/Base.xcconfig:31
> +MAYBE_HEADER_SEARCH_PATHS[sdk=macosx*] = mac/InternalHeaders $(NEXT_ROOT)/usr/local/include/WebCoreTestSupport $(BUILT_PRODUCTS_DIR)/usr/local/include $(BUILT_PRODUCTS_DIR)/WebCoreTestSupport ForwardingHeaders $(SRCROOT)/../../Source/JavaScriptCore/icu;

This doesn't need to be this long; it's duplicating paths in HEADER_SEARCH_PATHS:

PLATFORM_HEADER_SEARCH_PATHS[sdk=macosx*] = mac/InternalHeaders $(NEXT_ROOT)/usr/local/include/WebCoreTestSupport;

> Tools/DumpRenderTree/mac/Configurations/DebugRelease.xcconfig:31
> +MACOSX_DEPLOYMENT_TARGET[sdk=macosx*] = $(MACOSX_DEPLOYMENT_TARGET_$(PLATFORM_NAME));

It's redundant to use $(PLATFORM_NAME) here when [sdk=macosx*] will ensure that PLATFORM_NAME=macosx.  I would just say:

MACOSX_DEPLOYMENT_TARGET[sdk=macosx*] = $(MACOSX_DEPLOYMENT_TARGET_macosx);

And, in fact, you can merge this line with the next line to make:

MACOSX_DEPLOYMENT_TARGET[sdk=macosx*] = $(MACOSX_DEPLOYMENT_TARGET_macosx_$(TARGET_MAC_OS_X_VERSION_MAJOR));

> Tools/DumpRenderTree/mac/Configurations/DebugRelease.xcconfig:37
> +WEBKIT_SYSTEM_INTERFACE_LIBRARY[sdk=macosx*] = $(WEBKIT_SYSTEM_INTERFACE_LIBRARY_$(PLATFORM_NAME));

Similarly here you can merge this line with the next line:

WEBKIT_SYSTEM_INTERFACE_LIBRARY[sdk=macosx*] = $(WEBKIT_SYSTEM_INTERFACE_LIBRARY_macosx_$(TARGET_MAC_OS_X_VERSION_MAJOR));

> Tools/DumpRenderTree/mac/Configurations/DumpRenderTreeApp.xcconfig:30
> +OTHER_LDFLAGS = $(MAYBE_OTHER_LDFLAGS) $(ASAN_OTHER_LDFLAGS);

Please use PLATFORM_OTHER_LDFLAGS instead of MAYBE_OTHER_LDFLAGS.

> Tools/DumpRenderTree/mac/Configurations/DumpRenderTreeApp.xcconfig:31
> +MAYBE_OTHER_LDFLAGS[sdk=iphone*] = -l$(WEBKIT_SYSTEM_INTERFACE_LIBRARY) -lWebCoreTestSupport -force_load $(BUILT_PRODUCTS_DIR)/libDumpRenderTree.a -framework QuartzCore -framework CFNetwork -framework CoreFoundation -framework CoreGraphics -framework Foundation -framework GraphicsServices -framework ImageIO -framework MobileCoreServices -framework UIKit -framework WebCore -framework JavaScriptCore -framework WebKit $(OTHER_LDFLAGS_FONTS) $(ASAN_OTHER_LDFLAGS);

No need to include $(ASAN_OTHER_LDFLAGS) here as it's redundant with OTHER_LDFLAGS.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150508/6b2260e0/attachment-0001.html>


More information about the webkit-unassigned mailing list