[Webkit-unassigned] [Bug 134488] Async loading of image resources

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 31 12:36:37 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=134488

--- Comment #60 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 249755
  --> https://bugs.webkit.org/attachment.cgi?id=249755
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=249755&action=review

> Source/WebCore/loader/ImageLoader.cpp:77
> +    virtual void run()

Missing override. Does this really need to be public?

> Source/WebCore/loader/ImageLoader.cpp:196
> +    AtomicString attr = m_element.imageSourceURL();

attr is really not a great variable name.

> Source/WebCore/loader/ImageLoader.cpp:301
> +    AtomicString attr = m_element.imageSourceURL();

attr is not a great variable name.

> Source/WebCore/loader/ImageLoader.cpp:319
> +            doUpdateFromElement(false);

Boolean arguments like this are really not readable. We usually use enum classes to improve readability:
enum class ShouldBypassMainWorldContentSecurityPolicy { No, Yes };
doUpdateFromElement(ShouldBypassMainWorldContentSecurityPolicy::No);

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150331/c49b6113/attachment-0002.html>


More information about the webkit-unassigned mailing list