[Webkit-unassigned] [Bug 143052] Separate entry decoding from validation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 25 13:24:05 PDT 2015


--- Comment #5 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 249413
  --> https://bugs.webkit.org/attachment.cgi?id=249413

View in context: https://bugs.webkit.org/attachment.cgi?id=249413&action=review

>> Source/WebKit2/NetworkProcess/cache/NetworkCache.cpp:248
>> +        return useDecision <= UseDecision::Validate;
> nit: I think (useDecision == Use || useDecision == Validate) would be more readable. It is only 2 values to check so it is not too long.

Actually, returning false here will cause the Storage to remove the entry. We probably only want to do this if the useDecision is UseDecision::NoDueToDecodeFailure?

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150325/ab9fcc5e/attachment-0002.html>

More information about the webkit-unassigned mailing list