[Webkit-unassigned] [Bug 146473] Errors in read() are not handled in WTF::cryptographicallyRandomValuesFromOS.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jun 30 16:23:00 PDT 2015
https://bugs.webkit.org/show_bug.cgi?id=146473
Geoffrey Garen <ggaren at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |ggaren at apple.com
--- Comment #13 from Geoffrey Garen <ggaren at apple.com> ---
> That makes sense. Do you think the code you wrote is clearer than:
>
> if (currentRead >= 0)
> amountRead += currentRead;
> else if (!(errno == EAGAIN || errno == EINTR))
> crashUnableToReadFromURandom();
I like both. I would still use " != -1" instead of "> = 0". -1 is a sentinel value and I think it helps readability to call it out explicitly.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150630/01876b56/attachment.html>
More information about the webkit-unassigned
mailing list