<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body><span class="vcard"><a class="email" href="mailto:ggaren&#64;apple.com" title="Geoffrey Garen &lt;ggaren&#64;apple.com&gt;"> <span class="fn">Geoffrey Garen</span></a>
</span> changed
              <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Errors in read() are not handled in WTF::cryptographicallyRandomValuesFromOS."
   href="https://bugs.webkit.org/show_bug.cgi?id=146473">bug 146473</a>
        <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">CC</td>
           <td>
               &nbsp;
           </td>
           <td>ggaren&#64;apple.com
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Errors in read() are not handled in WTF::cryptographicallyRandomValuesFromOS."
   href="https://bugs.webkit.org/show_bug.cgi?id=146473#c13">Comment # 13</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Errors in read() are not handled in WTF::cryptographicallyRandomValuesFromOS."
   href="https://bugs.webkit.org/show_bug.cgi?id=146473">bug 146473</a>
              from <span class="vcard"><a class="email" href="mailto:ggaren&#64;apple.com" title="Geoffrey Garen &lt;ggaren&#64;apple.com&gt;"> <span class="fn">Geoffrey Garen</span></a>
</span></b>
        <pre><span class="quote">&gt; That makes sense. Do you think the code you wrote is clearer than:
&gt; 
&gt; if (currentRead &gt;= 0)
&gt;     amountRead += currentRead;
&gt; else if (!(errno == EAGAIN || errno == EINTR))
&gt;     crashUnableToReadFromURandom();</span >

I like both. I would still use &quot; != -1&quot; instead of &quot;&gt; = 0&quot;. -1 is a sentinel value and I think it helps readability to call it out explicitly.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>