[Webkit-unassigned] [Bug 146280] New: Improve binding generator naming for promise methods

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 24 08:33:57 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=146280

            Bug ID: 146280
           Summary: Improve binding generator naming for promise methods
    Classification: Unclassified
           Product: WebKit
           Version: 528+ (Nightly build)
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebCore Misc.
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: youennf at gmail.com

Following on bug 146060, we could do some improvements.

>> Source/WebCore/bindings/js/JSDOMPromise.h:62
>> +template<class JSClassName>
>
>The type here is the JavaScript class, not the JavaScript class name. I suggest the name WrapperClass here instead of JSClassName. Also, we almost always use typename rather >than class in templates, although I’m not entirely sure why.
>
>> Source/WebCore/bindings/js/JSDOMPromise.h:63
>> +inline JSC::JSValue callPromiseFunction(JSC::ExecState& state, JSClassName& jsObject, JSC::EncodedJSValue promiseFunction(JSC::ExecState*, JSClassName*, >JSC::JSPromiseDeferred*))
>
>A typical name used in bindings for what we are calling jsObject here is “wrapper”

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150624/52330e3a/attachment.html>


More information about the webkit-unassigned mailing list