[Webkit-unassigned] [Bug 144955] [ES6] Implement ES6 arrow function syntax. Parser of arrow function with execution as common function

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 19 09:48:25 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=144955

--- Comment #65 from GSkachkov <gskachkov at gmail.com> ---
Comment on attachment 254763
  --> https://bugs.webkit.org/attachment.cgi?id=254763
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=254763&action=review

>> Source/JavaScriptCore/parser/Parser.h:833
>> +#endif
> 
> Need to drop it.

Done

>> Source/JavaScriptCore/parser/SourceCode.h:129
>> +    }
> 
> Personally I think maintaining 2 same functions is error prone.
> In fact, RegExpPrototype.cpp is already using isLineTerminator. So I think using Lexer<UChar>::isLineTerminator not so problematic.
> Ideally, extracting these character related function into the different header from Lexer and this is nice.

Lexer.h already is linked to SourceCode.h so we would be had circular dependancy. Anyway I've modified logic little bit and get rid of the LineTerminator check.

>> Source/JavaScriptCore/parser/SourceProviderCacheItem.h:74
>>          token.m_location.endOffset = closeBraceOffset + 1;
> 
> Hmm, if m_type is not CLOSEBRACE, I think it's not correct because the token's endOffset is not closeBraceOffset + 1.
> And I think now `closeBraceOffset` name looks misleading because m_type may not be close brace.

I've added additional parameter to store end of the function

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150619/9caf45d6/attachment.html>


More information about the webkit-unassigned mailing list