[Webkit-unassigned] [Bug 144955] [ES6] Implement ES6 arrow function syntax. Parser of arrow function with execution as common function
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Jun 12 09:13:39 PDT 2015
https://bugs.webkit.org/show_bug.cgi?id=144955
Yusuke Suzuki <utatane.tea at gmail.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #254763|review?, commit-queue? |
Flags| |
--- Comment #61 from Yusuke Suzuki <utatane.tea at gmail.com> ---
Comment on attachment 254763
--> https://bugs.webkit.org/attachment.cgi?id=254763
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=254763&action=review
Thanks.
> Source/JavaScriptCore/ChangeLog:59
> + (JSC::SourceProviderCacheItem::endArrowFunctionToken):
It seems that ChangeLog is not updated.
I suggest using `Tools/Scripts/webkit-patch upload --update-changelogs`.
> Source/JavaScriptCore/parser/Parser.cpp:-1326
> - }
OK, the above sequence is related to the function's name. Splitting out from the `parseFunctionParameters` looks reasonable to me.
> Source/JavaScriptCore/parser/Parser.h:833
> +#endif
Need to drop it.
> Source/JavaScriptCore/parser/SourceCode.h:129
> + }
Personally I think maintaining 2 same functions is error prone.
In fact, RegExpPrototype.cpp is already using isLineTerminator. So I think using Lexer<UChar>::isLineTerminator not so problematic.
Ideally, extracting these character related function into the different header from Lexer and this is nice.
> Source/JavaScriptCore/parser/SourceProviderCacheItem.h:74
> token.m_location.endOffset = closeBraceOffset + 1;
Hmm, if m_type is not CLOSEBRACE, I think it's not correct because the token's endOffset is not closeBraceOffset + 1.
And I think now `closeBraceOffset` name looks misleading because m_type may not be close brace.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150612/d8b853ee/attachment.html>
More information about the webkit-unassigned
mailing list