<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body><span class="vcard"><a class="email" href="mailto:utatane.tea@gmail.com" title="Yusuke Suzuki <utatane.tea@gmail.com>"> <span class="fn">Yusuke Suzuki</span></a>
</span> changed
<a class="bz_bug_link
bz_status_NEW "
title="NEW - [ES6] Implement ES6 arrow function syntax. Parser of arrow function with execution as common function"
href="https://bugs.webkit.org/show_bug.cgi?id=144955">bug 144955</a>
<br>
<table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>What</th>
<th>Removed</th>
<th>Added</th>
</tr>
<tr>
<td style="text-align:right;">Attachment #254763 Flags</td>
<td>review?, commit-queue?
</td>
<td>
</td>
</tr></table>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - [ES6] Implement ES6 arrow function syntax. Parser of arrow function with execution as common function"
href="https://bugs.webkit.org/show_bug.cgi?id=144955#c61">Comment # 61</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - [ES6] Implement ES6 arrow function syntax. Parser of arrow function with execution as common function"
href="https://bugs.webkit.org/show_bug.cgi?id=144955">bug 144955</a>
from <span class="vcard"><a class="email" href="mailto:utatane.tea@gmail.com" title="Yusuke Suzuki <utatane.tea@gmail.com>"> <span class="fn">Yusuke Suzuki</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=254763&action=diff" name="attach_254763" title="Patch">attachment 254763</a> <a href="attachment.cgi?id=254763&action=edit" title="Patch">[details]</a></span>
Patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=254763&action=review">https://bugs.webkit.org/attachment.cgi?id=254763&action=review</a>
Thanks.
<span class="quote">> Source/JavaScriptCore/ChangeLog:59
> + (JSC::SourceProviderCacheItem::endArrowFunctionToken):</span >
It seems that ChangeLog is not updated.
I suggest using `Tools/Scripts/webkit-patch upload --update-changelogs`.
<span class="quote">> Source/JavaScriptCore/parser/Parser.cpp:-1326
> - }</span >
OK, the above sequence is related to the function's name. Splitting out from the `parseFunctionParameters` looks reasonable to me.
<span class="quote">> Source/JavaScriptCore/parser/Parser.h:833
> +#endif</span >
Need to drop it.
<span class="quote">> Source/JavaScriptCore/parser/SourceCode.h:129
> + }</span >
Personally I think maintaining 2 same functions is error prone.
In fact, RegExpPrototype.cpp is already using isLineTerminator. So I think using Lexer<UChar>::isLineTerminator not so problematic.
Ideally, extracting these character related function into the different header from Lexer and this is nice.
<span class="quote">> Source/JavaScriptCore/parser/SourceProviderCacheItem.h:74
> token.m_location.endOffset = closeBraceOffset + 1;</span >
Hmm, if m_type is not CLOSEBRACE, I think it's not correct because the token's endOffset is not closeBraceOffset + 1.
And I think now `closeBraceOffset` name looks misleading because m_type may not be close brace.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>