[Webkit-unassigned] [Bug 145800] NetworkCache: Delete old cache versions

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 9 10:07:38 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=145800

--- Comment #8 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 254568
  --> https://bugs.webkit.org/attachment.cgi?id=254568
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=254568&action=review

>>> Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:876
>>> +            String versionString = subdirName.substring(strlen(versionDirectoryPrefix));
>> 
>> We could use sizeof(versionDirectoryPrefix)-1 to resolve this at compile time instead of iterating over the string at runtime.
> 
> Modern compilers like clang constant fold calls to strlen, so this is resolved at compile time.

Ah, I did not know that. This is good to know. Please disregard my comment then, strlen() is a lot more readable :)

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150609/9553658e/attachment.html>


More information about the webkit-unassigned mailing list