<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - NetworkCache: Delete old cache versions"
href="https://bugs.webkit.org/show_bug.cgi?id=145800#c8">Comment # 8</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - NetworkCache: Delete old cache versions"
href="https://bugs.webkit.org/show_bug.cgi?id=145800">bug 145800</a>
from <span class="vcard"><a class="email" href="mailto:cdumez@apple.com" title="Chris Dumez <cdumez@apple.com>"> <span class="fn">Chris Dumez</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=254568&action=diff" name="attach_254568" title="patch">attachment 254568</a> <a href="attachment.cgi?id=254568&action=edit" title="patch">[details]</a></span>
patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=254568&action=review">https://bugs.webkit.org/attachment.cgi?id=254568&action=review</a>
<span class="quote">>>> Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:876
>>> + String versionString = subdirName.substring(strlen(versionDirectoryPrefix));
>>
>> We could use sizeof(versionDirectoryPrefix)-1 to resolve this at compile time instead of iterating over the string at runtime.
>
> Modern compilers like clang constant fold calls to strlen, so this is resolved at compile time.</span >
Ah, I did not know that. This is good to know. Please disregard my comment then, strlen() is a lot more readable :)</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>