[Webkit-unassigned] [Bug 147293] Implement WebAssembly module parser
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Jul 27 16:44:43 PDT 2015
https://bugs.webkit.org/show_bug.cgi?id=147293
Geoffrey Garen <ggaren at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #257558|review? |review+, commit-queue-
Flags| |
--- Comment #3 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 257558
--> https://bugs.webkit.org/attachment.cgi?id=257558
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=257558&action=review
r=me with some mixups
> Source/JavaScriptCore/parser/SourceProvider.h:90
> +#if ENABLE(WEBASSEMBLY)
> + virtual bool isStringSource() const override
> + {
> + return true;
> + }
> +#endif
SourceProvider has a subclass named "StringSourceProvider". This function is too easily confused with that class.
For now, I think you should remove this function. Instead of performing an isStringSource() check, I think you should just go with the [WebAssembly Source] source string you've provided. In the future, we'll have to see what the spec says about toString on a WebAssembly function.
> Source/JavaScriptCore/wasm/WASMFormat.h:33
> +static const uint32_t wasmMagicNumber = 0x6d736177;
This file should be named WASMMagicNumber.h.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150727/d4eb2e4f/attachment.html>
More information about the webkit-unassigned
mailing list