[Webkit-unassigned] [Bug 146837] Media Session: add plumbing for delivering start/end-of-interruption events
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Jul 13 10:46:02 PDT 2015
https://bugs.webkit.org/show_bug.cgi?id=146837
--- Comment #11 from Matt Rajca <mrajca at apple.com> ---
(In reply to comment #7)
> Comment on attachment 256610 [details]
> Patch
>
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=256610&action=review
>
> > Source/WebKit2/UIProcess/API/C/WKPage.cpp:2197
> > + switch (wkCategory) {
>
> I realize there's only one user, but the enum conversion functions are
> usually separate static methods. Maybe just keep that in mind if we end up
> needing this code again?
Will do.
>
> > Source/WebKit2/WebProcess/WebPage/WebPage.h:746
> > + void handleStartOfInterruptionEvent(uint32_t /* WebCore::MediaSessionInterruptingCategory */);
>
> Since this is on WebPage, it should be more clear that it's about media.
> Also, maybe just "handleMediaInterruptionEvent", with a state/phase to
> indicate whether it's starting or ending? Won't you eventually need the end
> case too?
I renamed it to 'handleMediaSessionInterruptionEvent' and added an enum for the event type (currently either start-of-interruption and end-of-interruption).
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150713/aa5b8c79/attachment-0001.html>
More information about the webkit-unassigned
mailing list