<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Media Session: add plumbing for delivering start/end-of-interruption events"
href="https://bugs.webkit.org/show_bug.cgi?id=146837#c11">Comment # 11</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Media Session: add plumbing for delivering start/end-of-interruption events"
href="https://bugs.webkit.org/show_bug.cgi?id=146837">bug 146837</a>
from <span class="vcard"><a class="email" href="mailto:mrajca@apple.com" title="Matt Rajca <mrajca@apple.com>"> <span class="fn">Matt Rajca</span></a>
</span></b>
<pre>(In reply to <a href="show_bug.cgi?id=146837#c7">comment #7</a>)
<span class="quote">> Comment on <span class="bz_obsolete"><a href="attachment.cgi?id=256610&action=diff" name="attach_256610" title="Patch">attachment 256610</a> <a href="attachment.cgi?id=256610&action=edit" title="Patch">[details]</a></span>
> Patch
>
> View in context:
> <a href="https://bugs.webkit.org/attachment.cgi?id=256610&action=review">https://bugs.webkit.org/attachment.cgi?id=256610&action=review</a>
>
> > Source/WebKit2/UIProcess/API/C/WKPage.cpp:2197
> > + switch (wkCategory) {
>
> I realize there's only one user, but the enum conversion functions are
> usually separate static methods. Maybe just keep that in mind if we end up
> needing this code again?</span >
Will do.
<span class="quote">>
> > Source/WebKit2/WebProcess/WebPage/WebPage.h:746
> > + void handleStartOfInterruptionEvent(uint32_t /* WebCore::MediaSessionInterruptingCategory */);
>
> Since this is on WebPage, it should be more clear that it's about media.
> Also, maybe just "handleMediaInterruptionEvent", with a state/phase to
> indicate whether it's starting or ending? Won't you eventually need the end
> case too?</span >
I renamed it to 'handleMediaSessionInterruptionEvent' and added an enum for the event type (currently either start-of-interruption and end-of-interruption).</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>