[Webkit-unassigned] [Bug 151243] Use multiple iOS simulator instead of multiple apps on single simulator for running layout-tests

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 8 10:14:24 PST 2015


https://bugs.webkit.org/show_bug.cgi?id=151243

Alexey Proskuryakov <ap at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #266839|review?, commit-queue?      |review+, commit-queue-
              Flags|                            |

--- Comment #9 from Alexey Proskuryakov <ap at webkit.org> ---
Comment on attachment 266839
  --> https://bugs.webkit.org/attachment.cgi?id=266839
Updated patch with review comments incorporated.

View in context: https://bugs.webkit.org/attachment.cgi?id=266839&action=review

> Tools/Scripts/webkitpy/port/ios.py:132
> +    def num_child_processes(self):

Please rename to just "child_processes" or "child_processes_option", as it's the same thing as the one in options.

> Tools/Scripts/webkitpy/port/ios.py:143
> +        # FIXME: We should also take into account the Add logic to take into account the available RAM.

Please fix the grammar, looks like two variants of the comment collided.

> Tools/Scripts/webkitpy/port/ios.py:148
> +            _log.warn("This machine could support %s child processes, but only has enough process limit for %s."
> +                % (best_child_process_count_for_cpu, maximum_simulator_count_on_this_system))
> +            _log.info('Run "launchctl limit" to check these limits')

Is there a reason to use different log levels here? These look like parts of the same message.

> Tools/Scripts/webkitpy/port/ios.py:280
> +            # FIXME: This creates the devices sequentially, this can be optimized.

I think that this can be more specific: "This creates the devices sequentially, doing this in parallel can improve performance".

> Tools/Scripts/webkitpy/port/ios.py:284
> +            # FIXME: this is very slow, especially for mulitple simulators, we probably do not need

Please start the sentence with an upper case letter ("This").

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151208/22c3b6ef/attachment.html>


More information about the webkit-unassigned mailing list