[Webkit-unassigned] [Bug 147745] Media Session: notify focus manager clients when the playing state of the focused media element changes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 6 14:40:50 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=147745

--- Comment #2 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 258396
  --> https://bugs.webkit.org/attachment.cgi?id=258396
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=258396&action=review

> Source/WebKit2/UIProcess/API/C/WKMediaSessionFocusManager.h:40
> +typedef void (*WKMediaSessionFocusManagerDidChangePlayingState)(WKMediaSessionFocusManagerRef manager, bool isPaused, const void *clientInfo);

Will this ever have to handle more than play/pause state changes? If so, I recommend changing the names to PlaybackState instead of PlayingState and passing flags instead of a bool.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150806/07960880/attachment.html>


More information about the webkit-unassigned mailing list