[Webkit-unassigned] [Bug 143480] [GStreamer] extra-headers and keep-alive properties for HTTP source element

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 7 09:19:14 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=143480

Carlos Garcia Campos <cgarcia at igalia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #250269|review?                     |review+
              Flags|                            |

--- Comment #7 from Carlos Garcia Campos <cgarcia at igalia.com> ---
Comment on attachment 250269
  --> https://bugs.webkit.org/attachment.cgi?id=250269
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=250269&action=review

> Source/WebCore/platform/graphics/gstreamer/GUniquePtrGStreamer.h:35
> +template<> struct GPtrDeleter<GstStructure> {
> +    void operator() (GstStructure* ptr) const
> +    {
> +        if (ptr)
> +            gst_structure_free(ptr);
> +    }
> +};

I just asked if we had this already, but now that we are adding it, it would be easier to use the WTF_DEFINE_GPTR_DELETER macro.

WTF_DEFINE_GPTR_DELETER(GstStructure, gst_structure_free)

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:479
> +        return FALSE;

false

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:485
> +    return TRUE;

true

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:491
> +        unsigned n = gst_value_array_get_size(value);

Sorry that I missed this in my previous review, use a more descriptive name than 'n' for the variable.

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:501
> +        unsigned n = gst_value_list_get_size(value);

Ditto.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150407/04aa5e1e/attachment.html>


More information about the webkit-unassigned mailing list