[Webkit-unassigned] [Bug 137553] abandoned select option is reselected when shift selecting new options
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Oct 15 13:46:52 PDT 2014
https://bugs.webkit.org/show_bug.cgi?id=137553
--- Comment #12 from Chris Dumez <cdumez at apple.com> 2014-10-15 13:46:45 PST ---
(From update of attachment 239868)
View in context: https://bugs.webkit.org/attachment.cgi?id=239868&action=review
> LayoutTests/ChangeLog:7
> +
Please add a description of the problem and how you are fixing it.
> LayoutTests/ChangeLog:8
> + * fast/forms/listbox-selection-after-typeahead-expected.txt: Added.
The usual format is Test: ...
Please refer to other Changelogs.
> LayoutTests/ChangeLog:9
> + * fast/forms/listbox-selection-after-typeahead.html: Added.
Shouldn't this test be in fast/dom/HTMLSelectElement/ ?
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:1
> +<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<!DOCTYPE html>
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:7
> +<p id="description"></p>
Not needed.
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:8
> +<div id="console"></div>
Not needed.
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:10
> +description('<p>Test for <i>'
No need to specify the bug URL here.
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:15
> +var parent = document.createElement('div');
Do we need to add those from JS? Can't be simply have them hardcoded in the <body>?
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:28
> +var sl1 = document.getElementById('sl1');
Could we use better names for the variables and ids please :)
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:29
> +var itemHeight = Math.floor(sl1.offsetHeight / sl1.size);
s11.options.length? Not sure why you're using a size attribute.
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:32
> +sl1.setAttribute('style', 'height: ' + height + 'px; border: 10px solid; padding: 5px;');
Why is this needed?
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:34
> +function mouseDownOnSelect(selId, index)
No abbreviations please
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:36
> + var sl = document.getElementById(selId);
Please use a better name than s1
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:55
> + for (var i = 0; i < select.options.length; i++)
++i
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:62
> +shouldBe('selectionPattern("sl1")', '"0100000"');
shouldBeEqualToString()
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:66
> +shouldBe('selectionPattern("sl1")', '"0000010"');
shouldBeEqualToString()
> LayoutTests/fast/forms/listbox-selection-after-typeahead.html:70
> +shouldBe('selectionPattern("sl1")', '"0000110"');
shouldBeEqualToString()
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list