[Webkit-unassigned] [Bug 138720] Refactor iOS selection gestures

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 17 15:30:16 PST 2014


--- Comment #6 from Enrica Casucci <enrica at apple.com> ---
> "beginSelectionInDirection" -> the name is also confusing. The "InDirection"
> is only loosely coupled with baseIsStart.
> > Source/WebKit2/WebProcess/WebPage/ios/WebPageIOS.mm:1616
> > +    m_selectionBaseIsStart = baseIsStart; // FIXME: do we need to flip this for RTL?
> I would find out and fix it instead of having a FIXME.

I agree with you. I'll change it to be direction (Forward/Backward in the interface) and change the bool to an enum to indicate which end of the selection is moving.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20141117/6490a190/attachment-0002.html>

More information about the webkit-unassigned mailing list