[Webkit-unassigned] [Bug 135476] Implement long mouse press over links. Part of 135257 - Add long mouse press gesture.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 1 14:13:12 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=135476


Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #235855|review?                     |review+
               Flag|                            |




--- Comment #4 from Simon Fraser (smfr) <simon.fraser at apple.com>  2014-08-01 14:13:23 PST ---
(From update of attachment 235855)
View in context: https://bugs.webkit.org/attachment.cgi?id=235855&action=review

> Source/WebCore/page/EventHandler.cpp:167
> +const double longMousePressDelay = 0.5;

This could use std::chrono so the units are explicit.

> Source/WebCore/page/EventHandler.cpp:168
> +const int longMousePressHysteresis = 5;

What is this value? Pixels? The name should make it clear.

> Source/WebCore/page/EventHandler.cpp:1583
> +    // FIXME: bubble long mouse press up to UI process.

This comment doesn't make sense here, since EventHandler is also used in non-mulitprocess mode.

> Source/WebCore/page/EventHandler.cpp:1588
> +    // FIXME: bubble long mouse press up to UI process.

Ditto, etc.

> Source/WebCore/page/EventHandler.cpp:1627
> +        if (FrameView* view = m_frame.view())
> +            view->setCursor(pointerCursor());

It seems a bit odd to reset the cursor here. Why?

> Source/WebCore/page/EventHandler.h:384
> +    bool mouseHysteresisExceeded(const FloatPoint&, const int) const;

The second parameter should be named here.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list