[Webkit-unassigned] [Bug 116049] Add a DisplayAndPowerController class to handle IOKit Display and Power notifications

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 13 22:16:42 PDT 2013


--- Comment #4 from Ryosuke Niwa <rniwa at webkit.org>  2013-05-13 22:15:09 PST ---
(In reply to comment #3)
> > I’d call this PowerSavingController instead.
> Hmm the display notification functionality is for power saving but the power notifications functionality is for shared timer stuff...plus I feel like the class can be used for more than just PowerSaving functionality in the future right?

It seems random that we have a controller for Display and Power. In general, we shouldn't name something in the anticipation of some new functionality in the future. We can rename it later if that day comes.

> > Why do these member functions and variables need to be in this class if they were private?
> > Can’t they just be on DisplayAndPowerControllerInternals instead?
> They access private variables of DisplayAndPowerController so I stuck them in the class to get around that.

Looking at the implementation, why does DisplayAndPowerController need any variable at all? It seems like we should move everything to DisplayAndPowerControllerInternals and just expose initDisplayAndPowerController() instead.

The controller doesn't have any API whatsoever.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list