[Webkit-unassigned] [Bug 94925] [EFL][UT]Refactoring an implementation of testing framework for wk1.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 13 08:22:34 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=94925





--- Comment #18 from Krzysztof Czech <k.czech at samsung.com>  2012-09-13 08:22:59 PST ---
(In reply to comment #17)
> (From update of attachment 163859 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=163859&action=review
> 
> Cool, quite better than before.
> thank you.
> 
> > Source/WebKit/efl/tests/UnitTestUtils/EWKTestBase.cpp:43
> > +Evas_Object* EWKTestBase::mainFrame()
> >  {
> > -    ecore_main_loop_quit();
> > +    return ewk_view_frame_main_get(webView());
> >  }
> 
> mainFrame looks not used now.
> 
> what do you think about adding this when it is really needed?
Alright.
> 
> > Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.cpp:32
> > +bool EWKTestView::init(int useX11Window, EwkViewType testViewType, int width, int height)
> 
> gyuyoung asked why useX11Window is int.
> Did you answer it?
Yes, I did it. int is used to have compatibility with getopt_long.
> 
> And when this function is called, I think that we should set webview to 0 first.
> If not, when we create new ecore_evas, previous ecore_evas will be removed before cleaning webview.
Generally this function should be called once per test case, then destruction is handled properly. If test case requires another page loading instead of loadUrl, ewk_view_uri_set(...) and waintUntilLoadFinished() should be called.
Initialization (init()) should be done only once per test case.
I thought about to move init() from loadUrl() and call it separately as a first statement of each new test. It might more readable.
What do you think ?
>  
> > Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.cpp:39
> > +    if (!m_ecoreEvas.get())
> 
> .get() is not required here.
Indeed.
> 
> > Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.cpp:58
> >          return false;
> 
> if (!m_webView)
>     return false;
Indeed.
> 
> > Source/WebKit/efl/tests/test_ewk_view.cpp:34
> > +    ewk_view_editable_set(webView(), EINA_FALSE);
Ups :), I haven't noticed, thanks.
> 
> s/EINA_FALSE/false

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list