[Webkit-unassigned] [Bug 98344] [EFL] Add the file system path set/get APIs.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 4 01:45:03 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=98344





--- Comment #3 from Dongwoo Joshua Im (dwim) <dw.im at samsung.com>  2012-10-04 01:45:28 PST ---
(In reply to comment #2)
> (From update of attachment 167043 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=167043&action=review
> 
> > Source/WebKit/efl/ewk/ewk_settings.cpp:153
> > +    WebCore::LocalFileSystem::initializeLocalFileSystem(WTF::String::fromUTF8(path));
> 
> WTF:: is probably not needed.
> 
> WebCore::LocalFileSystem::initializeLocalFileSystem() can only be called *ONCE* due to the ASSERT(!s_instance); in debug mode.
> This makes this API useless since ewk_settings_file_system_path_set() is already called once from ewk_main. Therefore, it is no longer possible for the app to change it later.
> 

What do you mean "app" in your comment above?

If you mean web apps, web apps are not supposed to change the path.
The url of web app will be used as the name of directory.
(e.g. <base_path>/<path_made_by_the_url>)

If you mean native apps, it could set the path using the XDG_DATA_HOME.

BTW, I need to use 'efreet_data_home_get' here, rather than 'efreet_cache_home_get'.


> > Source/WebKit/efl/ewk/ewk_settings.h:132
> > +EAPI void ewk_settings_file_system_path_set(const char* path);
> 
> Star on wrong side.
> 
Oh.. WebKit & EFL coding style always make me confused. ;)
I'll fix this.

> > Source/WebKit/efl/ewk/ewk_settings.h:145
> > +EAPI const char* ewk_settings_file_system_path_get(void);
> 
> Star on wrong side.
> 
same as above case.

> > Source/WebKit/efl/tests/test_ewk_settings.cpp:35
> > +* @brief Checking whether function properly returns correct value.
> 
> Missing space at beginning?
> 
Hmm.. 
I don't think it is mandatory, isn't it?

But It's not looks good, though.
I'll give a space there in the next patch.

> > Source/WebKit/efl/tests/test_ewk_settings.cpp:36
> > +*/
> 
> Ditto.
> 
same as above case.

> > Source/WebKit/efl/tests/test_ewk_settings.cpp:41
> > +    ewk_settings_file_system_path_set("/WebKitEfl/FileSystem");
> 
> I'm not sure it is a very good example to use "/WebKitEfl/FileSystem". This may lead to permission problems later.

The directory is only for unit test to see the API is working well.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list