[Webkit-unassigned] [Bug 87696] [FileAPI] Miss FileList test

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 29 01:55:53 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=87696


Kentaro Hara <haraken at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #144477|commit-queue?               |commit-queue-
               Flag|                            |




--- Comment #7 from Kentaro Hara <haraken at chromium.org>  2012-05-29 01:55:52 PST ---
(From update of attachment 144477)
View in context: https://bugs.webkit.org/attachment.cgi?id=144477&action=review

> LayoutTests/fast/files/file-list-test.html:7
> +<input type="file" name="file" id="file" multiple onchange="onInputFileChange(this.files)">

Nit: name="file" and id="file" are not needed.

> LayoutTests/fast/files/file-list-test.html:18
> +    shouldBeTrue("files.item(0) instanceof File");

Also you can test files.item(0).name and files.item(1).name to check if the correct files are stored?

shouldBeEqualToString('files.item(0).name', 'resources/UTF8.txt');
shouldBeEqualToString('files.item(1).name', 'resources/UTF8-2.txt');

> LayoutTests/fast/files/file-list-test.html:20
> +    finishJSTest();

You can remove this.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list