[Webkit-unassigned] [Bug 86591] New: [Refactoring] Move platform-specific code in Editor::respondToChangedSelection to the WebKit layer

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 16 01:01:18 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=86591

           Summary: [Refactoring] Move platform-specific code in
                    Editor::respondToChangedSelection to the WebKit layer
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Keywords: InChromiumBugs
          Severity: Normal
          Priority: P2
         Component: HTML Editing
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: hbono at chromium.org
                CC: rniwa at webkit.org, morrita at google.com, jpu at apple.com


Greetings,

Unfortunately, Editor::respondToChangedSelection() has platform-specific code that is hard to understand it as listed below. We should move this code to the WebKit layer for better readability.

  #if (!PLATFORM(MAC) && !PLATFORM(CHROMIUM)) || (PLATFORM(MAC) && (defined(BUILDING_ON_LEOPARD) || defined(BUILDING_ON_SNOW_LEOPARD)))
  #if PLATFORM(CHROMIUM)
          if (!m_frame->settings() || !m_frame->settings()->asynchronousSpellCheckingEnabled()) {
              if (RefPtr<Range> wordRange = newAdjacentWords.toNormalizedRange())
                  m_frame->document()->markers()->removeMarkers(wordRange.get(), DocumentMarker::Spelling);
          }
  #else
          // This only erases markers that are in the first unit (word or sentence) of the selection.
          // Perhaps peculiar, but it matches AppKit on these Mac OS X versions.
          if (RefPtr<Range> wordRange = newAdjacentWords.toNormalizedRange())
              m_frame->document()->markers()->removeMarkers(wordRange.get(), DocumentMarker::Spelling);
  #endif
  #endif

Regards,

Hironori Bono

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list