[Webkit-unassigned] [Bug 85575] [BlackBerry] Autofill backing store implementation upstream

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 4 10:44:56 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=85575





--- Comment #7 from Rob Buis <rwlbuis at gmail.com>  2012-05-04 10:44:56 PST ---
Hi Jonathan,

(In reply to comment #6)
> (From update of attachment 140251 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=140251&action=review
> 
> >> Source/WebCore/platform/network/blackberry/AutofillBackingStore.cpp:56
> >> +        m_database.close();
> > 
> > Should the dtor here do similar things like close()? Can you assure somewhow close() is called before the dtor is called? Is the dtor called at all?
> 
> well that's a good question. I think as AutofillBackingStore works as a singleton, close() should make as a private function and called from dtor, we shouldn't let people call close() explicitly.
> dtor should be called after exit main(), I'll make a build and debug it tomorrow to see if it works as expected, too tired today.
> I guess CredentialBackingStore has the same issue, sorry for that. Will fix it together with next patch. Thanks.

Sounds good. Also if you use DEFINE_STATIC_LOCAL for the singleton it should call the dtor, maybe you can debug that.
If you only call close() from the dtor then maybe you do not even need that function but just put the code in the dtor.
Looking forward to the patch :)
Cheers,

Rob.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list