[Webkit-unassigned] [Bug 88326] [BlackBerry] [DRT] DRT should be able to run interactively and support multiple processes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 15 01:01:44 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=88326





--- Comment #5 from Xiaobo Wang <xiaobo.wang at torchmobile.com.cn>  2012-06-15 01:01:43 PST ---
(In reply to comment #2)
> View in context: https://bugs.webkit.org/attachment.cgi?id=145995&action=review
> 
> > Tools/DumpRenderTree/blackberry/DumpRenderTree.cpp:170
> > +    m_doneFile = sdcardPath + "/done" + workerNumber;
> 
> Wouldn't use pid be better? We don't need to check this env var if we use getpid()
>
Yes we can use pid technically. But I think work number is a better choice.
1. To be consistent with NRWT. NRWT doesn't know the pid of the remote process on the device, it only knows the worker number. Worker number is a logical concept, stands for a worker. Pid of the launcher is more like its implementation, the value is meaningless to NRWT. 
2. To be meaningful to testers, making it easier to debug.

> > Tools/DumpRenderTree/blackberry/DumpRenderTree.cpp:242
> > +//        doneDrt();
> 
> code clean up?
>
Updated.

> > Tools/DumpRenderTree/blackberry/DumpRenderTree.cpp:328
> > +void DumpRenderTree::ensurePPS()
> 
> Can we make this as a bool function, so we can handle differently if PPS isn't ready?
>
Updated.

> > Tools/DumpRenderTree/blackberry/DumpRenderTree.cpp:336
> > +        currentPath += ("/" + nodes[i]);
> 
> Sorry, I'm a bit confused. what's the difference between the ppsPathString and currentPath here?
> 
Here I'm trying to mkdir recursively from root to the final path. It's just like "mkdir -p <path>".

> > Tools/DumpRenderTree/blackberry/DumpRenderTree.cpp:376
> > +                m_refTests.append(testFile);
> 
> isn't refTests being removed from here?
Yes, good catch. I was too lazy to rename it to a more meaningful one. Changed to m_bufferedTests. This vector is used to accept input from PPS while a test is being run.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list