[Webkit-unassigned] [Bug 76715] Refactor plugin drawing to be more data driven

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 27 11:05:06 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=76715





--- Comment #16 from Tim Dresser <tdresser at chromium.org>  2012-01-27 11:05:06 PST ---
(In reply to comment #15)
> I think you'll have to do your own double buffering for it to work correctly with incremental updates. Use two ioSurfaceTextureIds and flip between them for each update.

>From my understanding, this additional complexity has been introduced because we moved the texture creation code off the compositor thread.

It feels like things could be simplified significantly by moving everything back onto the compositor thread. 

Is there any advantage to allocating the ioSurfaceTexture on the main thread?

If I was to leave the allocation of the ioSurfaceTexture on the compositor thread, could I avoid the additional overhead of the ManagedTexture and double buffering?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list