[Webkit-unassigned] [Bug 76069] [GTK] ATK text-caret-moved and text-selection-changed events not being emitted

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 16 08:43:56 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=76069


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #122637|review?                     |review-
               Flag|                            |




--- Comment #7 from Martin Robinson <mrobinson at webkit.org>  2012-01-16 08:43:56 PST ---
(From update of attachment 122637)
View in context: https://bugs.webkit.org/attachment.cgi?id=122637&action=review

> Source/WebCore/accessibility/gtk/AccessibilityObjectWrapperAtk.cpp:2745
> +    AccessibilityObject* actualObject = focusedObject;

Is the goal here to find the first unignored object among the focused object and its parents? actualObject is a bad name, I think. Consider something like firstUnignoredParentOfFocusedObject.

> Source/WebCore/accessibility/gtk/AccessibilityObjectWrapperAtk.cpp:2761
> +    // Make sure the reference object gets now updated if the focused
> +    // object was pointing to it, so we don't have the reference
> +    // object as a descendant of the actual object being considered.
> +    if (focusedObject != referenceObject)
> +        referenceObject = actualObject;

This comment seems wrong: Should it say "Make sure the reference object is updated if the focused object was *different?" Can't you do this check more directly by just checking if referenceObject is a descendant of focusedObject or actualObject?

You say in your comment " so we don't have the reference object as a descendant of the actual object being considered," but this can still happen if focusedObject == referenceObject and focusedObject is ignored in the a11y tree.  I find this code, in general, pretty confusing.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list