[Webkit-unassigned] [Bug 79212] [BlackBerry] Upstream ImageBlackBerry in platform/graphics/blackberry

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 23 20:16:21 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=79212





--- Comment #6 from Robin Cao <robin.cao at torchmobile.com.cn>  2012-02-23 20:16:21 PST ---
(In reply to comment #5)
> (From update of attachment 128375 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=128375&action=review
> 
> > Source/WebCore/platform/graphics/blackberry/ImageBlackBerry.cpp:52
> > +        context->fillRect(FloatRect(0, 0, 16, 16), Color::white, ColorSpaceDeviceRGB);
> > +
> > +        if (!strcmp(name, "searchCancel"))
> > +            context->setFillColor(Color(128, 128, 128), ColorSpaceDeviceRGB);
> > +        else
> > +            context->setFillColor(Color(64, 64, 64), ColorSpaceDeviceRGB);
> > +
> > +        context->translate(8, 8);
> > +
> > +        context->rotate(piDouble / 4.0);
> > +        context->fillRect(FloatRect(-1, -7, 2, 14));
> > +
> > +        context->rotate(-piDouble / 2.0);
> > +        context->fillRect(FloatRect(-1, -7, 2, 14));
> 
> some magic numbers here. Anyway we could improve it?
> 

We just want to draw a "x" here. Maybe i should add a comment?

> > Source/WebCore/platform/graphics/blackberry/ImageBlackBerry.cpp:70
> > +    img->setData(buffer.release(), true);
> 
> what is true here?

true == allDataReceived
bool Image::setData(PassRefPtr<SharedBuffer> data, bool allDataReceived);

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list