[Webkit-unassigned] [Bug 75812] JSC should be a triple-tier VM

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 17 23:07:07 PST 2012


Gavin Barraclough <barraclough at apple.com> changed:

           What    |Removed                     |Added
 Attachment #127001|review?                     |review+
               Flag|                            |

--- Comment #105 from Gavin Barraclough <barraclough at apple.com>  2012-02-17 23:07:06 PST ---
(From update of attachment 127001)
View in context: https://bugs.webkit.org/attachment.cgi?id=127001&action=review

Okay, this basically all looks good.  Couple small of issues:

Please revert JSActivation.h & Heap.cpp (whitespace only changes).

Please rename Interpreter::enabled() (to make it clear which interpreter this is enabling - e.g. 'classicEnabled()' would be fine.)

Per our discussion, I think 'Helpers' isn't a great name, since it isn't descriptive of what it helps.  I'm happy with your suggested 'SlowPaths'.

It's a shame that LLIntOffsetsExtractor is LLInt specific – it seems this pattern could be generalized to provide offsets into classes for use by the JITs, too, and reduce the friendliness of the codebase.  But I'm not asking for this change in this patch, it's fine as is.

> Source/JavaScriptCore/llint/LowLevelInterpreter.asm:70
> +# These declarations must match interpreter/RegisterFile.h.

Are these constants defended anywhere by compile time ASSERTs?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list