[Webkit-unassigned] [Bug 75812] JSC should be a triple-tier VM

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 17 23:11:36 PST 2012


--- Comment #106 from Filip Pizlo <fpizlo at apple.com>  2012-02-17 23:11:36 PST ---
(In reply to comment #105)
> (From update of attachment 127001 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=127001&action=review
> Okay, this basically all looks good.  Couple small of issues:

Thanks! :-)

> Please revert JSActivation.h & Heap.cpp (whitespace only changes).


> Please rename Interpreter::enabled() (to make it clear which interpreter this is enabling - e.g. 'classicEnabled()' would be fine.)

Good idea.

> Per our discussion, I think 'Helpers' isn't a great name, since it isn't descriptive of what it helps.  I'm happy with your suggested 'SlowPaths'.

Will do.

> It's a shame that LLIntOffsetsExtractor is LLInt specific – it seems this pattern could be generalized to provide offsets into classes for use by the JITs, too, and reduce the friendliness of the codebase.  But I'm not asking for this change in this patch, it's fine as is.


> > Source/JavaScriptCore/llint/LowLevelInterpreter.asm:70
> > +# These declarations must match interpreter/RegisterFile.h.
> Are these constants defended anywhere by compile time ASSERTs?

Unfortunately not. :-(  I will add these to LLIntData.cpp, since LLInt initialization funnels through there.

I'd like to come up with a way of having these constants get extracted similarly to how we do offsets and sizes.  I'm not there yet. :-(

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list