[Webkit-unassigned] [Bug 98705] [EFL][WK2] Add Remote Web Inspector

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 5 22:40:54 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=98705





--- Comment #13 from Seokju Kwon <seokju.kwon at samsung.com>  2012-12-05 22:43:19 PST ---
(In reply to comment #12)
> (From update of attachment 177735 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=177735&action=review
> 
> > Source/WebKit2/UIProcess/InspectorServer/efl/WebInspectorServerEfl.cpp:42
> > +static String inspectorResourcePath()
> > +{
> > +    String inspectorFilesPath = WEB_INSPECTOR_INSTALL_DIR;
> > +    if (access(inspectorFilesPath.utf8().data(), R_OK))
> > +        inspectorFilesPath = WEB_INSPECTOR_DIR;
> > +
> > +    return inspectorFilesPath;
> > +}
> 
> IMHO, how about moving this into WebCore/platform/efl to reduce duplication?
> 
> For example, EflInspectorUtilities.h?
> 
> In addition, don't we return "file://" + inspectorFilesPath ?
> 
Good proposal. I will file a bug for it later.
we don't need "file://" for argument of file APIs.

> > Source/WebKit2/UIProcess/InspectorServer/efl/WebInspectorServerEfl.cpp:53
> > +    String localPath = inspectorResourcePath() + ((path == "/") ? "/inspectorPageIndex.html" : path);
> 
> Can we improve this line using https://trac.webkit.org/wiki/EfficientStrings ?
> 
Well, QT and GTK ports use it like this. 
I want to use it for consistency, if it's not bad.
Could you please let me know how to imprvoe if you have it?

> > Source/WebKit2/UIProcess/InspectorServer/efl/WebInspectorServerEfl.cpp:54
> > +    if (localPath.isNull())
> 
> I am wonering how localPath can be null
>
Right. Unnecessary code.

> > Source/WebKit2/UIProcess/InspectorServer/efl/WebInspectorServerEfl.cpp:98
> > +        builder.appendLiteral("\", \"inspectorUrl\": \"");
> > +        builder.appendLiteral("/inspector.html?page=");
> 
> As one line?
> 
IMO, It seems to make it more readable.

> > Source/WebKit2/UIProcess/efl/WebContextEfl.cpp:50
> > +        String bindAddress = "127.0.0.1";
> 
> ASCIILiteral("...")
> 
Ok.

> > Source/WebKit2/UIProcess/efl/WebContextEfl.cpp:54
> > +        serverAddress.split(":", result);
> 
> ':' ?
Ok.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list