[Webkit-unassigned] [Bug 91052] JSC: LLInt should auto-generate our cross-platform C++ interpreter

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 20 15:44:06 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=91052





--- Comment #22 from Geoffrey Garen <ggaren at apple.com>  2012-08-20 15:44:43 PST ---
> How much effort do you want to invest in generating more readable code considering that we will rarely have to debug at this level.

I hear you and Phil both saying that debug-ability doesn't matter here. But you invented a whole new syntax for comment-embedded pseudo-assembly because you said you couldn't debug without it. What gives?

FWIW, when I read this code, the comment-embedded pseudo-asssembly makes things harder to read, because now I'm speaking in three languages (LLInt assembly, c++, and pseudo-assembly) instead of two, and one of these languages has no specification and no debugger.

> Are you suggesting that I make the output look more like ASM code?  I can do that if its preferable.

My main suggestion is that any comment you would want to put on the right of the "//" would serve us better as code on the left of the "//". If you want to name an offset or a register on the right, just name it in the code on the left instead. Let's not use comments as a crutch to excuse unreadable code.

On the other hand, if you think the code is perfectly readable without the comments, or readability doesn't matter for some special reason in this case, please remove the comments.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list