[Webkit-unassigned] [Bug 81786] Initial support fixed position elements in Qt WebKit2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 3 05:13:21 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=81786





--- Comment #29 from Yael <yael.aharon at nokia.com>  2012-04-03 05:13:20 PST ---
(In reply to comment #28)
> (From update of attachment 135263 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=135263&action=review
> 
Thank you for the review :)
> > Source/WebCore/ChangeLog:8
> > +        When the setting acceleratedCompositingForFixedPositionEnabled is true, we need to upadte
> 
> update
> 
oops :)

> Couldn't the method be called something like userLayersForFixedElements or similar.
> 
acceleratedCompositingForFixedPositionEnabled is consistent with other settings for accelerated composition. If we choose to rename it, it probably should not go with this patch.

> > Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:517
> > +FloatPoint TextureMapperLayer::normalizedScrollOffset(const IntPoint& webScrollOffset)
> 
> web? This doesn't tell me whethre this is in CSS coords or not.
> 
I a not passing CSS information anymore. This is strictly about the scroll offset that the web process uses. You are right, position is better than offset here.

> > Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:520
> > +    float webScrollPositionX = std::max(webScrollOffset.x(), 0);
> > +    webScrollPositionX = std::min(webScrollPositionX, m_contentsSize.width() - m_visibleContentsRect.width());
> 
> isn't there something like qBound?
> 
This file is used by GTK folks too.

> This is offset from what? current position? because if so, then it should be possible to be negative. Or is this just scroll position?
> 
yes, this should be called position, not offset.

> > Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:538
> > +    float uiScrollPositionX = std::max(m_visibleContentsRect.x(), 0);
> 
> What value does ui add here?
> 
The purpose of this method is to compensate for the difference in scroll position between the UI process and the web process. The difference is due to the async nature of the IPC messages. I need to distinguish between the position in the UI side, and the position in the web side.

> > Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:539
> > +    uiScrollPositionX = std::min(uiScrollPositionX, m_contentsSize.width() - m_visibleContentsRect.width());
> 
> I have seen similar code elsewhere
> 
> > Source/WebKit2/Shared/WebLayerTreeInfo.cpp:38
> > +    encoder->encode(CoreIPC::In(scrollOffset));
> 
> scrollPosition?
> 
ok
> > Source/WebKit2/Shared/WebLayerTreeInfo.h:115
> > +    WebCore::IntPoint scrollOffset;
> 
> an offset would be IntSize where as a position would be IntPoint
ok

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list