[Webkit-unassigned] [Bug 69109] New: Refactor out trivially duplicated code in DFGJITCodeGenerator.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 29 16:14:23 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=69109

           Summary: Refactor out trivially duplicated code in
                    DFGJITCodeGenerator.
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: barraclough at apple.com
                CC: yuqiang.xian at intel.com


Some code is trivially redundant between DFGJITCodeGenerator.cpp & DFGJITCodeGenerator32_64.cpp

Basically move a JSVALUE64 specific code into a new DFGJITCodeGenerator64.cpp, leave common code in DFGJITCodeGenerator.cpp, and remove copies from DFGJITCodeGenerator32_64.cpp.

For some function differences are trivial & make more sense to ifdef individually, and some Operand methods make more sense left in DFGJITCodeGenerator.cpp alongside similar constructors.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list