[Webkit-unassigned] [Bug 40351] [chromium] Can't handle deletion of characters beyond U+10000.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 5 13:10:28 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=40351





--- Comment #4 from Alexey Proskuryakov <ap at webkit.org>  2011-09-05 13:10:28 PST ---
(From update of attachment 106334)
View in context: https://bugs.webkit.org/attachment.cgi?id=106334&action=review

Looks good.

> Source/WebCore/rendering/RenderText.cpp:1671
> +#if PLATFORM(MAC) || defined(OS_MACOSX)

I don't know if all other ports want this behavior when running on OS X, although I would certainly encourage them to.

> Source/WebCore/rendering/RenderText.cpp:1761
> +    StringImpl& text = *m_text.impl();
> +    if (U16_IS_TRAIL(text[--current]))
> +        --current;

Why did you store StringImpl in a local variable? Just accessing the text through m_text seems like it would be better for readability:

    if (U16_IS_TRAIL(m_text[--current]))

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list