[Webkit-unassigned] [Bug 70140] Flush denormals to zero on Windows.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 17 14:25:30 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=70140





--- Comment #11 from Chris Rogers <crogers at google.com>  2011-10-17 14:25:30 PST ---
Hi Ray, several of the fixes marked as "Done" are not actually in the latest patch - could you please re-check.

> > This will likely require changing certain other methods to also take "float" arguments
> 
> Yes we could.  I just wanted to keep this change self-contained.  But I can go and change the signature and all the callers appropriately.  I'd rather do that in two stages, though: This one for the important fix, and a follow-on with the targetGain and m_busGain change.

Ok, but then in that case please add a FIXME here

> > I'm not very fond of the name "FlushToFloatZero" -- I'd suggest including the word "denormal" in the name.
> > How about: "FlushFloatDenormalToZero"
> > 
> > Also, it's better to have functions like this be in some kind of namespace.  One idea is to move this inline function as a static inline method of DenormalDisabler
> 
> How about FlushDenormalFloatToZero?
> 
> I'll move it to a static inline method.

Seems fine to me.

> 
> >> Source/WebCore/platform/audio/DenormalDisabler.h:43
> >> +#define FlushToFloatZero(f) static_cast<float>(f)
> > 
> > It seems odd that on Windows this is an inline function, and otherwise is a macro -- maybe just have it uniformly be a static inline method of DenormalDisabler
> 
> That's just an implementation detail; just made it obvious there's no impact even on debug builds.  But I won't have a choice if I make it an static inline method.

I know, but it's more of a consistency/style readability thing

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list