[Webkit-unassigned] [Bug 64865] Switch isQuirkValue() virtual function to inline one.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Oct 15 15:52:58 PDT 2011


--- Comment #27 from David Barr <davidbarr at chromium.org>  2011-10-15 15:52:57 PST ---
(From update of attachment 111150)
View in context: https://bugs.webkit.org/attachment.cgi?id=111150&action=review

>> Source/WebCore/css/CSSPrimitiveValue.h:140
>> +     */
> We use "//" comments, not "/*" comments. Not sure why you changed this one.

I was matching style with the nearest comment block in the destination file, which just happened to be the only incorrectly styled comment in the whole file. Will fix.

>> Source/WebCore/css/CSSPrimitiveValue.h:143
>> +        CSSPrimitiveValue *ptr = new CSSPrimitiveValue(value, type);
> The "*" goes next to the type, not the local variable name.
> Instead of ptr this local variable should be named value.

Given that the parameter is also called value, I'll take the liberty of calling it quirkValue.
This has the advantage that the middle line reads quite clearly:
quirkValue->m_isQuirkValue = true;

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list