[Webkit-unassigned] [Bug 69753] [GTK] Initial UI client implementation for WebKit2 GTK +API

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 11 00:23:16 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=69753





--- Comment #7 from Martin Robinson <mrobinson at webkit.org>  2011-10-11 00:23:16 PST ---
(In reply to comment #6)
> (In reply to comment #4)
> > (From update of attachment 110349 [details] [details])

> I think web view is actually the ui client, that's why I haven't used a separate client for this. I you want the ui client separated from the page, we should probably add a page class like Gustavo suggested. 

The WebKitWebView is the actual widget, but the UIClient controls everything surrounding the WebView. I think it makes sense to split them into two things.  For instance, setMenuBarIsVisible has no relation to the WebView widget at all. There are some delegates that I associate with the widget itself such as focus and unfocus -- maybe we can consider having the UIClient just fire signals on the WebView.  What do you think?

Do you mind expanding a bit on how the existence of a page client would change things?

> 
> > I believe that the ::ready signal should be called ::show to match the underlying API.
> 
> I find "show" very confusing.

Do you mind elaborating a bit on this?

> > > Source/WebKit2/UIProcess/API/gtk/WebKitWebView.cpp:66
> > > +static GtkWidget* webkitWebViewCreate(WebKitWebView*)
> > > +{
> > > +    return 0;
> > > +}
> > 
> > This seems to be dead code?
> 
> No, it's the default implementation, it's only called when the signal is not handled.

Ah, I see it now! Thanks.

> > > Source/WebKit2/UIProcess/API/gtk/WebKitWebView.cpp:108
> > > +        webView,/* clientInfo */
> > > +        0,      /* createNewPage_deprecatedForUseWithV0 */
> > > +        showPage,
> > > +        closePage,
> > > +        0,      /* takeFocus */
> > > +        0,      /* focus */
> > > +        0,      /* unfocus */
> > > +        0,      /* runJavaScriptAlert */
> > > +        0,      /* runJavaScriptConfirm */
> > > +        0,      /* runJavaScriptPrompt */
> > > +        0,      /* setStatusText */
> > > +        0,      /* mouseDidMoveOverElement_deprecatedForUseWithV0 */
> > > +        0,      /* missingPluginButtonClicked */
> > > +        0,      /* didNotHandleKeyEvent */
> > > +        0,      /* didNotHandleWheelEvent */
> > > +        0,      /* toolbarsAreVisible */
> > > +        0,      /* setToolbarsAreVisible */
> > 
> > You should use C++ style comments here and they should be one space away from the 0,.
> 
> Didn't you ask me to line this up before?

If I did, I apologize. I noticed that the style bot was complaining about them recently.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list