[Webkit-unassigned] [Bug 69630] [GStreamer] webkitwebsrc: avoid GST_BOILERPLATE_FULL

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 7 08:58:17 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=69630





--- Comment #4 from Martin Robinson <mrobinson at webkit.org>  2011-10-07 08:58:18 PST ---
(From update of attachment 110150)
View in context: https://bugs.webkit.org/attachment.cgi?id=110150&action=review

>> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:136
>> +                        GST_DEBUG_CATEGORY_INIT(webkit_web_src_debug, "webkitwebsrc", 0, "websrc element"););
> 
> More than one command on the same line  [whitespace/newline] [4]

You can split this out into two macros if you wish:

// We split this out into another macro to avoid a check-webkit-style error.
#define WEBKIT_WEB_SRC_CATEGORY_INIT GST_DEBUG_CATEGORY_INIT(webkit_web_src_debug, "webkitwebsrc", 0, "websrc element");
G_DEFINE_TYPE_WITH_CODE(WebKitWebSrc, webkit_web_src, GST_TYPE_BIN,
                         G_IMPLEMENT_INTERFACE(GST_TYPE_URI_HANDLER, webKitWebSrcUriHandlerInit);
                         WEBKIT_WEB_SRC_CATEGORY_INIT);

>> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:138
>> +static void webkit_web_src_class_init(WebKitWebSrcClass* klass)
> 
> webkit_web_src_class_init is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]

I think it would be good to do something similar to here: https://bugs.webkit.org/show_bug.cgi?id=69481

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list