[Webkit-unassigned] [Bug 69409] [GTK] [WebKit2] Make adding another unit test easier

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 5 23:40:36 PDT 2011


--- Comment #10 from Carlos Garcia Campos <cgarcia at igalia.com>  2011-10-05 23:40:36 PST ---
(In reply to comment #9)
> Carlos, I examined your patch again and I think it is  not not so different from mine. I see a few main differences:

Yes, as I said, my patch is based on yours.

> 1. main() is inside a #define and depends on the fact that a test suite can only use one type of fixture. 
> 2. Tests are embedded in the fixtures.
> 3. The files use their original names.
> Number 3 is not so important to me, but I do believe we should name the tests after the API they test - testloading -> testwebloaderclient, etc.
> Number 1 and 2 are pretty important to me though. Fixtures should be independent of tests, we should be able to share them between suites and suites should be able to mix and match fixtures. That's the main reason I wanted to do this. Perhaps we can reach some sort of compromise on the rest?

Ok, I just wanted to avoid having another library if it is not really needed, and I didn't like having the main() in the library and the beforAll() afterAll() methods, I think we can have a class where befor/fater is just the constructor/destructor. But anyway, I don't want to block all new patches on this, and I agree on the idea of making adding new tests easier, so if xan and kov like your proposal it's fine with me.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list