[Webkit-unassigned] [Bug 60377] [Qt] fast/canvas/webgl/gl-uniform-arrays.html failing for Qt on Linux

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 24 10:03:14 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=60377





--- Comment #26 from Idrees <sidreesshah at hotmail.com>  2011-05-24 10:03:14 PST ---
(In reply to comment #25)
> (From update of attachment 94622 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=94622&action=review
> 
> > Source/WebCore/html/canvas/WebGLRenderingContext.cpp:2446
> > -        if (info.size > 1)
> > +        if (info.size > 1 && info.name.endsWith("[0]"))
> 
> Is "[0]" the only thing we should be stripping. What about "[1]"?

Yes, because if its an array the first element will be either just a name or it will end with [0]. There is no way it will end with [1].

> This looks like a testable change, why is there no new test in this patch?

The test case that i have attached is actually failing without this change for qtwebkit. because we are truncating the last three characters without verifying if they are really [0]. "getActiveUniform" gives only "color" as the name for "info" even its an array. So we need to make sure we are not truncating the name of the uniform itself.

> 
> > Source/WebCore/platform/graphics/qt/GraphicsContext3DQt.cpp:-1448
> > -    ASSERT(program);
> 
> This should be in a separate patch.

Ok. I have created two different patches now. But the same test case can be applied for both. So i have added it to the changelog.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list